admin.atlassian.com is not accessible
Incident Report for Jira Service Management
Resolved
Between 09:52 AM UTC to 12:47 PM UTC, we experienced issue impacting access to admin.atlassian.com through the browser. The issue has been resolved and the service is operating normally.
Posted May 26, 2022 - 12:55 UTC
Identified
We are gradually seeing sites recovering with access to admin.atlassian.com through the browser . We're continuing to monitor the service and deploy the fix.
Posted May 26, 2022 - 11:33 UTC
Investigating
We are investigating an issue that is impacting access to admin.atlassian.com through the browser. We will provide more details within the next hour.
Posted May 26, 2022 - 11:17 UTC
This incident affected: Signup.