Specific JSM APIs don't return email address of portal-only customers
Incident Report for Jira Service Management
Resolved
Between 2020-11-11 03:06 AM UTC to 2020-11-16 06:25 AM UTC we experienced issues with APIs in Jira Service Management. Additionally, email address information was not shown correctly in user profile cards for JSM portal-only customers, reporter and request participant information in UI was not showing email address details.
Posted Nov 16, 2020 - 06:40 UTC
Identified
We're experiencing some issues with APIs in Jira Service Management, the following APIs are not returning email addresses of JSM portal-only customers:
- .atlassian.net/rest/api/2/search?jql=id=&expand=changelog&maxResults=1
- .atlassian.net/rest/api/2/search?jql=id=
- .atlassian.net/rest/api/3/users/search?accountId=%

Additionally:
- User profile cards are incorrectly hiding the email address for JSM portal-only customers
- Reporter or Request Participant information in UI is not showing email address information as well
Posted Nov 16, 2020 - 06:14 UTC
This incident affected: Authentication and User Management.