Application modules - e.g. general page - may fail to render for some Connect Apps
Incident Report for Jira Service Management
Resolved
We have found the change that introduced unexpected behavior and reverted it. The connect app modules now should work correctly

Technical details: the URL should now contain empty query parameters and QSH should be valid for such URLs.

Impact started at 2022-09-27 7:40 UTC when change was activated and was mitigated at 2022-09-27 13:22 UTC when change was reverted.

This incident impacted internal beta release instances owned by connect application developers.
The change was reverted before it was deployed to regular production customers.

We will follow internally with post incident review process to ensure similar impact will not re-occur in the future.
Posted Sep 27, 2022 - 14:22 UTC
Investigating
We are investigating incident where connect apps modules fail to load in specific condition.

Technical details: This is know to affect connect modules using app-specific context parameters with empty values - those are failing due to invalid qsh signature.

Next update will be posted at 15:00 UTC
Posted Sep 27, 2022 - 13:07 UTC
This incident affected: Jira Service Mangement Web.