Degraded performance in Opsgenie and JSM operations

Incident Report for Jira Service Management

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 16:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 15:42 UTC

Investigating

We are investigating degraded performance issues in Jira Service Management, Opsgenie, and Compass Cloud customers. We will provide more details within the next hour.
Posted Jun 19, 2025 - 15:22 UTC