Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health to receive notifications if a reliability incident affects your organization.
Get webhook notifications whenever Jira Service Management creates an incident, updates an incident, resolves an incident or changes a component status.
Our team has been able to validate that all rule executions are performing normally and this issue is now resolved.
Posted Jul 22, 2026 - 00:56 UTC
Identified
The team has identified a root cause and after initial testing, is now enacting scaling changes to help to prevent these rule execution delays. We'll monitor performance over the next 24 hours and provide an update at that time or sooner if we can confirm the improvement is in place.
Posted Jul 21, 2026 - 04:53 UTC
Update
Our teams are continuing to investigate delays in Jira and Jira Service Management automation rule executions for some customers. We are seeing signs of improvement, but affected users may still experience delays. We'll share updates here as more information is available.
Posted Jul 20, 2026 - 21:27 UTC
Investigating
We are actively investigating reports of performance degradation affecting Automation rules for Jira and Jira Service Management. We will share updates here as more information is available.
Posted Jul 20, 2026 - 20:18 UTC
This incident affected: Jira Service Management Web, Service Portal, Opsgenie Incident Flow, Opsgenie Alert Flow, Opsgenie Incident Flow, Opsgenie Alert Flow, Jira Service Management Email Requests, Authentication and User Management, Purchasing & Licensing, Signup, Automation for Jira, Assist, and Assets.