Delays in automation rules execution

Incident Report for Jira Service Management

Resolved

Between to , we experienced delays in Automation rule execution for Jira Service Management and Jira. The issue has been resolved and the service is operating normally. All new rule submissions are executed normally. For the old (backlog) rules, the system is catching up and will complete them in the next 6-12 hours.
Posted Jul 16, 2025 - 18:43 UTC

Monitoring

We are continuing to recover and automation delays are decreasing. We are monitoring the progress and will provide an update with the next hour.
Posted Jul 16, 2025 - 18:09 UTC

Identified

We continue to work on resolving the automation rules delay for Jira Service Management and Jira. We are currently mitigating the issue. Expect the next update within the next hour.
Posted Jul 16, 2025 - 17:07 UTC

Investigating

We are investigating cases of degraded performance for Automation rules execution in Jira Service Management and Jira Cloud customers. We will provide more details within the next hour.
Posted Jul 16, 2025 - 15:34 UTC
This incident affected: Automation for Jira.