Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health to receive notifications if a reliability incident affects your organization.
Get webhook notifications whenever Jira Service Management creates an incident, updates an incident, resolves an incident or changes a component status.
On June 10 2026, between 08:10 and 09:08 UTC, users experienced degraded performance and inability to load the Assets page, which is impacting the ability to create, update, and delete assets.
We have implemented a fix and services have been restored to normal operation for all affected customers.
Posted Jun 10, 2026 - 10:00 UTC
Investigating
Users are facing degraded performance while accessing Assets page which is impacting Assets object creation, updation and deletion activities. Our teams are investigating actively and will be sharing more details in next 1 hour.
Posted Jun 10, 2026 - 09:42 UTC
This incident affected: Jira Service Management Web.