Degraded Performance Viewing Issues and Boards

Incident Report for Jira Service Management

Resolved

On September 24th 2026, some Jira and JSM users in the US region may have experienced a performance degradation impacting Jira issue creation, issue viewing, and board loading. The issue has now been resolved, and the service is operating normally for all affected customers.
Posted Sep 24, 2026 - 15:53 UTC

Monitoring

Mitigations have been deployed and we are seeing positive signs of recovery across Jira. Issues viewing work items, loading boards, and creating tickets are subsiding.

We are continuing to monitor system health to ensure full stability and will share our next update within 60 minutes.
Posted Sep 24, 2026 - 14:58 UTC

Investigating

We continue to investigate the issue impacting Jira issue creation, issue viewing, and board loading.

Our teams remain engaged on identifying a resolution. We will provide the next update in 1 hour, or sooner if there is material progress.
Posted Sep 24, 2026 - 13:54 UTC
This incident affected: Jira Service Management Web and Service Portal.