Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System health (currently in Beta) to receive notifications if a reliability incident affects your organization
Get webhook notifications whenever Jira Service Management creates an incident, updates an incident, resolves an incident or changes a component status.
Between 00:00 UTC to 01:05 UTC 14 April, users attempting to load the Administration page for Atlassian products. The issue has been resolved and the service is operating normally.
Posted Apr 14, 2025 - 01:33 UTC
Investigating
We are aware of an issue where users attempting to load the Administration page are instead seeing a blank page. Our team is investigating with urgency and will provide further update as soon as possible.
Posted Apr 14, 2025 - 00:37 UTC
This incident affected: Jira Service Management Web.