JSM/JIRA microsoft mail puller degraded performance

Incident Report for Jira Service Management

Resolved

JSM and JIRA mail puller services have recovered and are back in normal operating status. For more information, please check Microsoft status updates at this link: https://portal.office.com/servicestatus
Posted 1 month ago. Mar 01, 2025 - 23:58 UTC

Monitoring

Microsoft has resolved the issue and we are currently monitoring performance for Jira and JSM.
Posted 1 month ago. Mar 01, 2025 - 23:42 UTC

Investigating

We are currently experiencing degraded performance with Microsoft mail services. We are investigating the issue with Microsoft
Posted 1 month ago. Mar 01, 2025 - 23:13 UTC
This incident affected: Jira Service Management Email Requests.